:note

ElectronとNative Module

以前作った Electron を流用して新しい Electron アプリを作るときに、 Module versionの不一致というエラーがでて対処法をしらべた

46がv4, 47がv5ということらしい

node は v4.2.1

Module version mismatch. Expected 47, got 46. · Issue #344 · polotek/libxmljs

no helpful information here to debug this nor do I think you have done any googling around for how to resolve this issue. You upgraded node without rebuilding the module.

Previous Releases | Node.js

結果的に、Native Moduleを利用している時には electronの process.versionと実行するnodejsのバージョンがあっていないとダメらしい

electron -v => v0.36.7

process.version => v5.1.1

nvm で v5.1.1 をインストールし、nvm use 5.1.1 して npm install し直したら解決した

後で知った、もっと簡単な方法があったらしい

electron/using-native-node-modules.md at master · atom/electron

electron/using-native-node-modules.md at master · atom/electron

 
comments powered by Disqus
back to top