:note

brew pin imagemagickでv6に固定

rmagickがimagemagick7にまだ対応してないので、うっかりhomebrewでアップグレードしないように固定する。

mini_magickは imagemagick7の変更の影響を受けない。

Rmagick does not seem to be compatible with Imagemagick 7 · Issue #265 · rmagick/rmagick

ruby - ImageMagick 7 with RMagick 2.16 on MacOS Sierra Can’t find MagickWand.h - Stack Overflow

% brew info imagemagick
imagemagick: stable 7.0.5-2 (bottled), HEAD
Tools and libraries to manipulate images in many formats
https://www.imagemagick.org/
/usr/local/Cellar/imagemagick/6.9.2-10 (1,456 files, 17.7MB)
  Poured from bottle on 2016-01-06 at 13:28:06
/usr/local/Cellar/imagemagick/6.9.3-7_1 (1,459 files, 18MB)
  Poured from bottle on 2016-05-06 at 09:40:52
/usr/local/Cellar/imagemagick/6.9.6-4 (1,467 files, 22.3MB)
  Poured from bottle on 2016-11-16 at 09:59:31
/usr/local/Cellar/imagemagick/6.9.7-3 (1,465 files, 22.3MB) *
  Poured from bottle on 2017-01-10 at 09:49:41
...
...
...
--without-modules
	Disable support for dynamically loadable modules
--without-threads
	Disable threads support
--HEAD
	Install HEAD version

brew pin でバグのあるバージョンを避ける例 - @znz blog

% brew pin imagemagick
% brew info imagemagick
imagemagick: stable 7.0.5-2 (bottled), HEAD [pinned at 6.9.7-3]
...
...
...

rmagickがimagemagick7に対応したら unpin してアップグレードする。

% brew unpin imagemagick
 
comments powered by Disqus
back to top